IOS/Router

Top / IOS / Router


Router

VLANϢ

Switch

VLAN֥롼ƥ

  • SwitchΥȥ󥯥롼
  • VLANȤ˥֥󥿥եƤ
  • ֥󥿥եIDVLANIDϰפۤ
    (config-if)#encapsulation dot1q <vlan-id>
    

OSPF

  • 饹쥹Υ󥯥ơȥ롼ƥ󥰥ץȥ
    ! ospfͭ
    (config)#router ospf <process-id>
    
    ! ospfưͥåȥλ
    (config-router)#network <address> <wildcard-mask> area <area-id>
    
    ! ǧ
    #show ip protocols
    #show ip route
    #show ip ospf
    #show ip ospf [interface <interface>|neighbor <neighbor-id>]
    
    ! ǥХå
    #debug ip ospf events
    
    • process-idϥ롼Ǥμ̤ΤߤѤ롣¾롼Ȥΰפ
    • area-id¾롼ȰפʤȥͥФΩʤ

롼ID

  • Ǥդʸ󡢤ޤϥ롼ץХåɥ쥹󥿥եIPɥ쥹Ѥ
    ! Ǥդʸѡ侩
    (config-router)#router-id <router-id>
    
    ! 롼ץХåɥ쥹ѡʿ侩
    !! 롼ץХåĤäƥɥ쥹ꤹ
    (config)#interface loopback <loopback-id>
    

ɥХ

! ȥѥξ
(config-router)#maximum-paths <value>

! Ȥθ
(config-if)#ip ospf cost <value>

ǧ

  • ץ졼ƥǧڤMD5ǧڤݡȤ
    ! 󥿥եñ̤ǥѥɤ
    (config-if)#ip ospf authentication-key <password>
    
    ! 󥿥եñ̤ޤϥꥢñ̤ǧڤͭʲΤɤ餫¹ԡ
    (config-if)#ip ospf authentication [message-digest|null]
    (config-router)#area <area-id> authentication [message-digest]
    
    ! ǥХå
    #debug ip ospf adj
    

EIGRP

  • 饹쥹ĥǥ󥹥٥롼ƥ󥰥ץȥ롣뤤ϥϥ֥åɥ롼ƥ󥰥ץȥ

! eigrpͭ
(config)#router eigrp <as-number>

! eigrpưͥåȥλ
(config-router)#network <address>

! ưڤʤϢ³ͥåȥб
(config-router)#no auto-summary

! ǧ
#show ip route eigrp
#show ip protocols
#show ip eigrp [interfaces|neighbors [detail]|topology [all]|traffic]

! ǥХå
#debug ip eigrp
  • as-numberƱeigrpư롼֤ǰפ
  • addressʲ˥ޥƤ⤤ʥ磻ɥɡ

ɥХ

! ȥɥХ󥹤ȥѥξ
(config-router)#maximum-paths <value>

! ȥɥХ󥹤ΥХꥢ󥹤
(config-router)#valiance <value>

ǧ

  • MD5ǧڤΤߥݡ
    ! Ĥ
    (config)#key chain <key-chain-name>
    
    ! ˥ɲä
    (config-keychain)#key <key-id>
    
    ! ɲä򤹤
    !! ѥɤ
    (config-keychain-key)#key-string <password>
    !! ɬפʤ¤ߤ
    (config-keychain-key)#accept-lifetime <hh:mm:ss month date year> {infinitie|<end-time>|duration <seconds>}
    (config-keychain-key)#send-lifetime <hh:mm:ss month date year> {infinitie|<end-time>|duration <seconds>}
    
    ! MD5ǧڤͭ
    (config-if)#ip authentication mode eigrp <as-number> md5
    
    ! ǧڤǻȤλ
    (config-if)#ip authentication key-chain eigrp <as-number> <key-chain-name>
    
    

ACL

ɸACL

! Ĥ
!! ֹƱˤֹˤ֤鲼ʣΥȥ꤬Ĥ
(config)#access-list <access-list-number> {permit|deny|remark} <source-address> [wildcard-mask]

! ä
!! ֹñ̤Ǥޤ뤴Ⱦä
(config)#no access-list <access-list-number>
!! ȥꤴȤ˾ä
(config-std-nacl)#no <seq-number>
  • access-list-number1-99

ĥACL

! Ĥ
!! ֹƱˤֹˤ֤鲼ʣΥȥ꤬Ĥ
(config)#access-list <access-list-number> {permit|deny} <protocol> <source-address> <wildcard-mask> [<operator> {<app-name>|<port-number>}] <destination-address> <wildcard-mask> [<operator> {<app-name>|<port-number>}] [established] [log]

! ä
!! ֹñ̤Ǥޤ뤴Ⱦä
(config)#no access-list <access-list-number>
!! ȥꤴȤ˾ä
(config-ext-nacl)#no <seq-number>
  • protocoliptcpudpicmpȤ
  • establishedACK=1RST=1ʥѥåȤ̤
    • ̿κǽΰSYN=1Τߤ顢Υץ椬ǽ

̾դACL

  • ֹǤϤʤ̾ǴACLɸĥɤäĤ
  • ̾ʬֹˤд¸ACLȥԽǽ
    ! Ĥ
    !! ޤ̾ݡθŪʥȥɲä
    (config)#ip access-list {standard|extended} <access-list-name>
    
    !! ɸACLĤȤ
    (config-std-nacl)#[seq-number] {permit|deny} <source-address> [wildcard-mask]
    
    !! ĥACLĤȤ
    (config-ext-nacl)#[sec-number] {permit|deny} <protocol> <source-address> <wildcard-mask> <destination-address> <wildcard-mask> [precedence <precedence>] [tos <tos>]
    
    ! ä
    !! ̾ñ̤Ǥޤ뤴Ⱦä
    (config)#no access-list {standard|extended} <access-list-name>
    !! ȥꤴȤ˾ä
    (config-{std|ext}-nacl)#no <seq-number>
    

ȤĤ

! ֹդACLξ
(config)#access-list <access-list-number> remark <comment>

! ̾դACLξ
(config-{std|ext}-nacl)#remark <comment>

ǧ

#show ip access-list

ѥåȥե륿

  • acl򥤥󥿥եŬѤ
    ! 󥿥եACLŬѤ
    (config-if)#ip access-group <access-list-number> {in|out}
    
    ! vtyؤΥ¤
    !! ɸACLΤ
    (config-line)#access-class <access-list-number> {in|out}
    
    ! ǧ
    #show ip interface <interface>
    
    • access-list-number̾դACLŬѤaccess-list-nameˤ

NATPAT

IPv6

PPP

ե졼졼


Last-modified: 2011-09-03 () 21:51:36 (2330d)