IOS/Switch

Top / IOS / Switch

Switch

  • åطΥޥ
  • ե륹ڥǽ񤤤Ƥ
  • ե⡼ɤڤؤϾά

VLANϢ

VTP

  • VLANͥåȥǼưŪ˶ͭ뵻
    ! 
    (config)#vtp mode [server|client|transparent]
    (config)#vtp domain <domain-name>
    (config)#vtp password <password>
    (config)#vtp pruning
    
    ! ǧ
    #show vtp status
    #show vtp counters
    

ȥ󥭥

  • 802.1QåƱΤ³ʣVLANΥȥեå뵻
    ! 
    (config-if)#switchport mode [access|dynamic [auto|desirable]|trunk]
    
    !! ץ벽
    (config-if)#switchport trunk encapsulation {dot1q|isl}
    
    !! VLAN
    (config-if)#switckport trunk allowed vlan [add|except|remove|all] <vlan-id>
    
    !! ͥƥVLAN
    !! ISLˤϥͥƥVLANϤʤ
    (config-if)#switchport trunk native vlan <vlan-id>
    
    !! DTPѥåȤʤ=ͥȤʤ
    (config-if)#switchport nonegotiate
    
    ! ǧ
    #show interfaces <interface> [switchport|trunk]
    
    SW1SW2ͥȷ
    desirabledesirabletrunk
    autodesirabletrunk
    autoautoaccess

VLAN

  • ޥɥˡ
    ! VLANκ
    (config)#vlan <vlan-id>
    (config-vlan)#name <vlan-name>
    
    ! 󥿥եγ
    (config-if)#switchport access vlan <vlan-id>
    
    ! ǧ
    #show vlan [brief|id <vlan-id>|name <vlan-name>]
    
  • Ťˡ
    ! VLANκ
    #vlan database
    (vlan)#vlan <vlan-id>
    
    ! ȿ
    (vlan)#apply
    (vlan)#exit
    

VLAN֥롼ƥ

STP

PortFast

! Υ󥿥եPortFastˤ
(config-if)#spannning-tree portfast

! ٤Ƥȥ󥯥󥿥եPortFastˤ
(config)#spanning-tree portfast default

! ǧ
# show runnning-config interface <interface>

RSTP

! 
(config)#spanning-tree mode rapid-pvst

! ǧ
#show spanning-tree vlan <vlan-id> [detail]

! ǥХå
#debug spanning-tree pvst+
#debug spanning-tree switch state
! 롼ȥ֥å֥å
(config)#spanning-tree vlan <vlan-id> root [primary|secondary]

! ץ饤ƥŪʻ4096ñ̡
(config)#spanning-tree vlan <vlan-id> priority <priority>

Last-modified: 2011-09-03 () 21:50:59 (2513d)